Filtrar por:

Os seus filtros aparecerão aqui.

Foi encontrada 456 questões

Julgue o item subsequente, relativo à lógica de programação.
 
O pseudocódigo a seguir, após executado, apresentará como resultado 2.370.
 
inteiro contador = 1;
inteiro exp = 1;
real y = 0;
real aux = 1;
real n = 1;
 
faça {
   y = (1 + (1 / n));
 
   enquanto (exp <= contador) {
    aux = y * aux;
    exp++;
   }
 
   exp = 1;
   escreva(aux);
 
   contador++;
   aux = 1;
   n++;
 
} enquanto (contador <= 2);
O operador de incremento ++ pode ser pré-fixado ou pós-fixado, e quando aplicado a uma operação pode gerar resultados diferentes dependendo de como for aplicado.

No exemplo abaixo, qual o resultado correto da operação?

int a = 7;
int b = 7;
int c = 2 * ++a;
int d = 2 * b++;

Considere o algoritmo em pseudocódigo a seguir:
 
 
01. Algoritmo REPETICAO
02. Var
03.       parcial, num, resultado : real
04.       cont : inteiro
05. Início
06.       parcial \leftarrow 0;
07.       cont \leftarrow 0;
08.       Enquanto cont < 10 faça
09.       Início
10.             Ler(num)
11.       parcial \leftarrow parcial + num
12.             cont \leftarrow cont + 1
13.       Fim
14.       resultado \leftarrow parcial / cont
15.       Mostrar(“Resultado = ”,resultado)
16. Fim.
 
Analise as seguintes afirmativas sobre o algoritmo:
 
I. O algoritmo usa uma estrutura de repetição com teste no início.
 
II. O algoritmo irá calcular a média dos números de 0 a 9.
 
III. O comando “Mostrar” irá exibir o valor da variável “resultado” no dispositivo padrão de saída.
 
Estão CORRETAS as afirmativas:
Atenção: Para responder a questão, considere o algoritmo em pseudocódigo abaixo.

var
x, y, i: inteiro
result: real

inicio
   leia (x)
   leia (y)
   result \leftarrow1

se (y > 0)
entao inicio
              para i \leftarrow1 ate y passo 1 faça
              inicio
                   result \leftarrow result * x
              fim para
         fim entao
senao inicio
            y \leftarrow y * (−1)
            para i\leftarrow1 ate y passo 1 faça
            inicio
                 result \leftarrow result * (1/x)
            fim para
        fim senao
  imprima (result)
fim
 
Considerando o algoritmo apresentado é correto afirmar que se
Atenção: Para responder a questão, considere o algoritmo em pseudocódigo abaixo.

var
x, y, i: inteiro
result: real

inicio
   leia (x)
   leia (y)
   result \leftarrow1

se (y > 0)
entao inicio
              para i \leftarrow1 ate y passo 1 faça
              inicio
                   result \leftarrow result * x
              fim para
         fim entao
senao inicio
            y \leftarrow y * (−1)
            para i\leftarrow1 ate y passo 1 faça
            inicio
                 result \leftarrow result * (1/x)
            fim para
        fim senao
  imprima (result)
fim
 
No algoritmo apresentado